Fornex
Европейский
хостинг

    Vulners-Scanner - это сканер уязвимостей на основе PoC, использующий API vulners.com. Скрипт собирает информацию об установленных в системе пакетах, и сообщает администратору о наличии уязвимостей в них.

    Имейте ввиду, что для запуска программы нужно установить Python.

    Для использования сканера доступны два скрипта — lazyScanner.py и linuxScanner.py.
    Результатом выполнения скриптов будет информация о найденных в системе потенциально уязвимых мест.

    Установка и запуск lazyScanner.py

    # git clone https://github.com/videns/vulners-scanner
    # cd vulners-scanner
    # ./lazyScanner.py
    
    [root@kvmde54-19861 ~]# git clone https://github.com/videns/vulners-scanner
    Cloning into 'vulners-scanner'...  
    remote: Enumerating objects: 82, done.  
    remote: Total 82 (delta 0), reused 0 (delta 0), pack-reused 82  
    Unpacking objects: 100% (82/82), done.  
    
    [root@kvmde54-19861 ~]# cd vulners-scanner
    
    [root@kvmde54-19861 vulners-scanner]# ./lazyScanner.py
    OS Name - centos, OS Version - 7  
    Total provided packages: 637  
    Traceback (most recent call last):  
      File "./lazyScanner.py", line 95, in <module>
        scanner.auditSystem()
      File "./lazyScanner.py", line 80, in auditSystem
        response = urllib2.urlopen(req, json.dumps(payload).encode('utf-8'))
      File "/usr/lib64/python2.7/urllib2.py", line 154, in urlopen
        return opener.open(url, data, timeout)
      File "/usr/lib64/python2.7/urllib2.py", line 437, in open
        response = meth(req, response)
      File "/usr/lib64/python2.7/urllib2.py", line 550, in http_response
        'http', request, response, code, msg, hdrs)
      File "/usr/lib64/python2.7/urllib2.py", line 475, in error
        return self._call_chain(*args)
      File "/usr/lib64/python2.7/urllib2.py", line 409, in _call_chain
        result = func(*args)
    

    Установка и запуск linuxScanner.py

    # git clone https://github.com/videns/vulners-scanner
    # cd vulners-scanner
    # ./linuxScanner.py
    
    [root@kvmde54-19861 /]# git clone https://github.com/videns/vulners-scanner
    Cloning into 'vulners-scanner'...  
    remote: Enumerating objects: 82, done.  
    remote: Total 82 (delta 0), reused 0 (delta 0), pack-reused 82  
    Unpacking objects: 100% (82/82), done.  
    
    [root@kvmde54-19861 /]# cd vulners-scanner
    
    [root@kvmde54-19861 vulners-scanner]# ./linuxScanner.py
    
                 _
    __   ___   _| |_ __   ___ _ __ ___  
    \ \ / / | | | | '_ \ / _ \ '__/ __|
     \ V /| |_| | | | | |  __/ |  \__ \
      \_/  \__,_|_|_| |_|\___|_|  |___/
    
    ==========================================
    Host info - Host machine  
    OS Name - centos, OS Version - 7  
    Total found packages: 635  
    Traceback (most recent call last):  
      File "./linuxScanner.py", line 125, in <module>
        scannerInstance.scan(checkDocker=False)
      File "./linuxScanner.py", line 110, in scan
        hostInstance = self.auditSystem(sshPrefix=None,systemInfo="Host machine")
      File "./linuxScanner.py", line 78, in auditSystem
        response = self.sendVulnRequest(url, payload)
      File "./linuxScanner.py", line 56, in sendVulnRequest
        response = urllib2.urlopen(req, json.dumps(payload).encode('utf-8'))
      File "/usr/lib64/python2.7/urllib2.py", line 154, in urlopen
        return opener.open(url, data, timeout)
      File "/usr/lib64/python2.7/urllib2.py", line 437, in open
        response = meth(req, response)
      File "/usr/lib64/python2.7/urllib2.py", line 550, in http_response
        'http', request, response, code, msg, hdrs)
      File "/usr/lib64/python2.7/urllib2.py", line 475, in error
        return self._call_chain(*args)
      File "/usr/lib64/python2.7/urllib2.py", line 409, in _call_chain
        result = func(*args)
      File "/usr/lib64/python2.7/urllib2.py", line 558, in http_error_default
        raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
    

    Проверка скриптов с помощью сайта vulners.com

    На сайте доступна функция аудита, для этого необходимо вывести список пакетов, установленных в системе, и указать их на странице https://vulners.com/audit

    Отобразить список пакетов можно, например, так (для CentOS и Ubuntu, Debian):

    # rpm -qa --qf '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n'
    # dpkg-query -W -f='${Package} ${Version} ${Architecture}\n'
    
    [root@kvmde54-19861 vulners-scanner]# rpm -qa --qf '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n'
    iwl3160-firmware-25.30.13.0-76.el7.noarch  
    compat-libtidy-0.99.0-37.20091203.el7.x86_64  
    perl-HTML-Parser-3.71-4.el7.x86_64  
    tar-1.26-35.el7.x86_64  
    libsepol-2.5-10.el7.i686  
    mariadb-libs-5.5.65-1.el7.x86_64  
    rdma-core-22.4-2.el7_8.i686  
    libssh2-1.8.0-3.el7.x86_64  
    libtool-ltdl-2.4.2-22.el7_3.x86_64  
    gettext-0.19.8.1-3.el7.x86_64  
    lcms2-2.6-3.el7.x86_64  
    jsoncpp-0.10.5-2.el7.x86_64  
    binutils-2.27-43.base.el7_8.1.x86_64  
    nettle-2.7.1-8.el7.x86_64  
    libXmu-1.1.2-2.el7.x86_64  
    libcurl-7.29.0-57.el7.x86_64  
    libXi-1.7.9-1.el7.x86_64  
    php-mysql-5.4.16-48.el7.x86_64  
    urw-base35-d050000l-fonts-20170801-10.el7.noarch  
    yum-utils-1.1.31-54.el7_8.noarch  
    libunistring-0.9.3-9.el7.x86_64  
    graphite2-1.3.10-1.el7_3.x86_64  
    acl-2.2.51-15.el7.x86_64  
    slang-2.2.4-11.el7.x86_64  
    libpng-1.5.13-7.el7_2.x86_64  
    libc-client-2007f-16.el7.x86_64  
    libselinux-utils-2.5-15.el7.x86_64  
    keyutils-libs-1.5.8-3.el7.x86_64  
    libpaper-1.1.24-8.el7.x86_64  
    perl-Text-ParseWords-3.29-4.el7.noarch  
    libpcap-1.5.3-12.el7.x86_64  
    pkgconfig-0.27.1-4.el7.x86_64  
    librsvg2-2.40.20-1.el7.x86_64  
    perl-Time-HiRes-1.9725-3.el7.x86_64  
    util-linux-2.23.2-63.el7.x86_64  
    ispmanager-plugins-5.259.1-1.el7.x86_64  
    perl-threads-1.87-4.el7.x86_64  
    libgnome-keyring-3.12.0-1.el7.x86_64  
    systemd-libs-219-73.el7_8.6.x86_64  
    ispmanager-pkg-php-5.259.1-1.el7.x86_64  
    screen-4.1.0-0.25.20120314git3c2946.el7.x86_64  
    mariadb-5.5.65-1.el7.x86_64  
    rsync-3.1.2-10.el7.x86_64  
    lsscsi-0.27-6.el7.x86_64  
    dhcp-common-4.2.5-79.el7.centos.x86_64  
    mod_fcgid-2.3.9-6.el7.x86_64  
    perl-Getopt-Long-2.40-3.el7.noarch  
    iptables-services-1.4.21-34.el7.x86_64  
    dbus-python-1.1.1-9.el7.x86_64  
    libcap-ng-0.7.5-4.el7.x86_64  
    avahi-libs-0.6.31-20.el7.x86_64  
    newt-python-0.52.15-4.el7.x86_64  
    pciutils-libs-3.5.1-3.el7.x86_64  
    teamd-1.29-1.el7.x86_64  
    libpwquality-1.2.3-5.el7.x86_64  
    phpMyAdmin-4.4.15.10-4.el7.noarch  
    libgcrypt-1.5.3-14.el7.i686  
    rsyslog-8.24.0-52.el7.x86_64  
    alsa-tools-firmware-1.1.0-1.el7.x86_64  
    selinux-policy-targeted-3.13.1-266.el7.noarch  
    nginx-module-geoip-1.16.1-1.el7.ngx.x86_64  
    perl-IO-Compress-2.061-2.el7.noarch  
    chrony-3.4-1.el7.x86_64  
    php-kolab-net-ldap3-1.0.7-2.el7.noarch  
    vim-enhanced-7.4.629-6.el7.x86_64  
    bind-license-9.11.4-16.P2.el7_8.3.noarch  
    php-pspell-5.4.16-48.el7.x86_64  
    php-pear-Mail-mimeDecode-1.5.5-7.el7.noarch  
    glibc-common-2.17-307.el7.1.x86_64  
    python-chardet-2.2.1-3.el7.noarch  
    sed-4.2.2-6.el7.x86_64  
    perl-HTTP-Daemon-6.01-8.el7.noarch  
    perl-CGI-3.63-4.el7.noarch  
    libdb-5.3.21-25.el7.x86_64  
    iwl100-firmware-39.31.5.1-76.el7.noarch  
    libXau-1.0.8-2.1.el7.x86_64  
    perl-libs-5.16.3-295.el7.x86_64  
    iwl4965-firmware-228.61.2.24-76.el7.noarch  
    pciutils-3.5.1-3.el7.x86_64  
    file-libs-5.11-36.el7.x86_64  
    zlib-1.2.7-18.el7.i686  
    coreutils-8.22-24.el7.x86_64  
    libetpan-1.6-1.el7.x86_64  
    pam-1.1.8-23.el7.i686  
    libmount-2.23.2-63.el7.x86_64  
    libICE-1.0.9-9.el7.x86_64  
    shellinabox-2.20-5.el7.x86_64  
    iptables-1.4.21-34.el7.x86_64  
    pcre-8.32-17.el7.x86_64  
    libXt-1.1.5-3.el7.x86_64  
    perl-libwww-perl-6.05-2.el7.noarch  
    python-linux-procfs-0.4.11-4.el7.noarch  
    OpenEXR-libs-1.7.1-7.el7.x86_64  
    nss-3.44.0-7.el7_7.x86_64  
    perl-Error-0.17020-2.el7.noarch  
    libXrandr-1.5.1-2.el7.x86_64  
    rpm-4.11.3-43.el7.x86_64  
    urw-base35-z003-fonts-20170801-10.el7.noarch  
    postgresql-libs-9.2.24-4.el7_8.x86_64  
    libassuan-2.1.0-3.el7.x86_64  
    urw-base35-standard-symbols-ps-fonts-20170801-10.el7.noarch  
    bind-libs-lite-9.11.4-16.P2.el7_8.3.x86_64  
    libtiff-4.0.3-32.el7.x86_64  
    libss-1.42.9-17.el7.x86_64  
    libdaemon-0.14-7.el7.x86_64  
    adobe-mappings-pdf-20180407-1.el7.noarch  
    perl-Pod-Perldoc-3.20-4.el7.noarch  
    vim-common-7.4.629-6.el7.x86_64  
    mesa-libEGL-18.3.4-7.el7_8.1.x86_64  
    perl-Time-Local-1.2300-2.el7.noarch  
    libjpeg-turbo-1.2.90-8.el7.x86_64  
    os-prober-1.58-9.el7.x86_64  
    coremanager-5.259.0-1.el7.x86_64  
    perl-File-Temp-0.23.01-3.el7.noarch  
    dracut-033-568.el7.x86_64  
    ispmanager-pkg-httpd-5.259.1-1.el7.x86_64  
    libmicrohttpd-isp-0.9.48-2.el7.centos.x86_64  
    dbus-1.10.24-13.el7_6.x86_64  
    libmodman-2.0.1-8.el7.x86_64  
    ispmanager-plugin-revisium-5.259.1-1.el7.x86_64  
    cronie-anacron-1.4.11-23.el7.x86_64  
    NetworkManager-libnm-1.18.4-3.el7.x86_64  
    gmp-6.0.0-15.el7.x86_64  
    cracklib-2.9.0-11.el7.x86_64  
    ntp-4.2.6p5-29.el7.centos.x86_64  
    php-pear-Net-Sieve-1.3.4-4.el7.noarch  
    mysqltuner-1.7.13-1.git.59e5f40.el7.noarch  
    proftpd-1.3.5e-9.el7.x86_64  
    python-setuptools-0.9.8-7.el7.noarch  
    libattr-2.4.46-13.el7.x86_64  
    perl-Compress-Raw-Zlib-2.061-4.el7.x86_64  
    plymouth-0.8.9-0.33.20140113.el7.centos.x86_64  
    exim-4.93-3.1.el7.x86_64  
    bzip2-libs-1.0.6-13.el7.i686  
    filesystem-3.2-25.el7.x86_64  
    etckeeper-1.18.14-1.el7.noarch  
    aspell-0.60.6.1-9.el7.x86_64  
    dnsmasq-2.76-10.el7_7.1.x86_64  
    perl-Net-DNS-0.72-6.el7.x86_64  
    qemu-guest-agent-2.12.0-3.el7.x86_64  
    libgsasl-1.8.0-8.el7.x86_64  
    centos-release-7-8.2003.0.el7.centos.x86_64  
    augeas-1.4.0-9.el7_8.1.x86_64  
    gpgme-1.3.2-5.el7.x86_64  
    vim-filesystem-7.4.629-6.el7.x86_64  
    php-mcrypt-5.4.16-9.el7.x86_64  
    libsepol-2.5-10.el7.x86_64  
    nginx-filesystem-1.16.1-1.el7.noarch  
    dejavu-sans-fonts-2.33-6.el7.noarch  
    libacl-2.2.51-15.el7.x86_64  
    dmidecode-3.2-3.el7.x86_64  
    perl-HTTP-Date-6.02-8.el7.noarch  
    sqlite-3.7.17-8.el7_7.1.x86_64  
    iwl2030-firmware-18.168.6.1-76.el7.noarch  
    php-php-gettext-1.0.12-1.el7.noarch  
    freetype-2.8-14.el7.x86_64  
    iwl6050-firmware-41.28.5.1-76.el7.noarch  
    perl-HTTP-Negotiate-6.01-5.el7.noarch  
    openssl-libs-1.0.2k-19.el7.x86_64  
    libdb-5.3.21-25.el7.i686  
    python-2.7.5-88.el7.x86_64  
    urw-base35-fonts-common-20170801-10.el7.noarch  
    libspf2-1.2.10-5.20150405gitd57d79fd.el7.x86_64  
    libaio-0.3.109-13.el7.x86_64  
    freetds-1.1.20-1.el7.x86_64  
    perl-Net-HTTP-6.06-2.el7.noarch  
    python-urlgrabber-3.10-10.el7.noarch  
    libglvnd-1.0.1-0.8.git5baa1e5.el7.x86_64  
    libgpg-error-1.12-3.el7.x86_64  
    libnl3-3.2.28-4.el7.x86_64  
    gd-2.0.35-26.el7.x86_64  
    nss-sysinit-3.44.0-7.el7_7.x86_64  
    libglvnd-glx-1.0.1-0.8.git5baa1e5.el7.x86_64  
    php-pear-Net-SMTP-1.7.3-1.el7.noarch  
    rpm-libs-4.11.3-43.el7.x86_64  
    xorg-x11-server-utils-7.7-20.el7.x86_64  
    php-mbstring-5.4.16-48.el7.x86_64  
    urw-base35-bookman-fonts-20170801-10.el7.noarch  
    groff-base-1.22.2-8.el7.x86_64  
    libnl3-cli-3.2.28-4.el7.x86_64  
    GeoIP-1.5.0-14.el7.x86_64  
    jasper-libs-1.900.1-33.el7.x86_64  
    sysvinit-tools-2.88-14.dsf.el7.x86_64  
    augeas-libs-1.4.0-9.el7_8.1.x86_64  
    cups-libs-1.6.3-43.el7.x86_64  
    unzip-6.0-21.el7.x86_64  
    libwmf-lite-0.2.8.4-41.el7_1.x86_64  
    ipset-7.1-1.el7.x86_64  
    recode-3.6-38.el7.x86_64  
    fipscheck-lib-1.4.1-6.el7.x86_64  
    device-mapper-1.02.164-7.el7_8.2.x86_64  
    perl-File-Path-2.09-2.el7.noarch  
    ispmanager-pkg-dovecot-5.259.1-1.el7.x86_64  
    systemd-219-73.el7_8.6.x86_64  
    ispmanager-pkg-roundcube-5.259.1-1.el7.x86_64  
    libmnl-1.0.3-7.el7.x86_64  
    policycoreutils-2.5-34.el7.x86_64  
    dhcp-libs-4.2.5-79.el7.centos.x86_64  
    dracut-network-033-568.el7.x86_64  
    mariadb-server-5.5.65-1.el7.x86_64  
    libdrm-2.4.97-2.el7.x86_64  
    libattr-2.4.46-13.el7.i686  
    libmicrohttpd-0.9.33-2.el7.x86_64  
    python-configobj-4.7.2-7.el7.noarch  
    cpio-2.11-27.el7.x86_64  
    plymouth-scripts-0.8.9-0.33.20140113.el7.centos.x86_64  
    libopendmarc-1.3.2-1.el7.x86_64  
    perl-Digest-1.17-245.el7.noarch  
    kbd-1.15.5-15.el7.x86_64  
    qrencode-libs-3.4.1-3.el7.x86_64  
    pcre-8.32-17.el7.i686  
    python-ipaddress-1.0.16-2.el7.noarch  
    kexec-tools-2.0.15-43.el7.x86_64  
    libntlm-1.3-6.el7.x86_64  
    php-tcpdf-dejavu-sans-fonts-6.2.26-1.el7.noarch  
    crontabs-1.11-6.20121102git.el7.noarch  
    nginx-module-xslt-1.16.1-1.el7.ngx.x86_64  
    perl-Geo-IP-1.43-3.el7.x86_64  
    mozjs17-17.0.0-20.el7.x86_64  
    iputils-20160308-10.el7.x86_64  
    hwdata-0.252-9.5.el7.x86_64  
    libestr-0.1.9-2.el7.x86_64  
    e2fsprogs-1.42.9-17.el7.x86_64  
    grub2-common-2.02-0.81.el7.centos.noarch  
    php-process-5.4.16-48.el7.x86_64  
    tzdata-2020a-1.el7.noarch  
    xfsprogs-4.5.0-20.el7.x86_64  
    libselinux-2.5-15.el7.x86_64  
    psmisc-22.20-16.el7.x86_64  
    libuuid-2.23.2-63.el7.x86_64  
    iwl3945-firmware-15.32.2.9-76.el7.noarch  
    perl-File-Listing-6.04-7.el7.noarch  
    diffutils-3.3-5.el7.x86_64  
    xz-libs-5.2.2-1.el7.x86_64  
    perl-Business-ISBN-2.06-2.el7.noarch  
    libffi-3.0.13-19.el7.x86_64  
    tbb-4.1-9.20130314.el7.x86_64  
    basesystem-10.0-7.el7.centos.noarch  
    perl-HTTP-Cookies-6.01-5.el7.noarch  
    ca-certificates-2019.2.32-76.el7_7.noarch  
    libpciaccess-0.14-1.el7.x86_64  
    pam-1.1.8-23.el7.x86_64  
    python-libs-2.7.5-88.el7.x86_64  
    libsysfs-2.1.0-16.el7.x86_64  
    awstats-7.7-1.el7.noarch  
    shared-mime-info-1.8-5.el7.x86_64  
    libXext-1.3.3-3.el7.x86_64  
    xz-5.2.2-1.el7.x86_64  
    libgomp-4.8.5-39.el7.x86_64  
    mesa-libglapi-18.3.4-7.el7_8.1.x86_64  
    ethtool-4.8-10.el7.x86_64  
    freetds-libs-1.1.20-1.el7.x86_64  
    virt-what-1.18-4.el7.x86_64  
    gsettings-desktop-schemas-3.28.0-3.el7.x86_64  
    chkconfig-1.7.4-1.el7.x86_64  
    libxshmfence-1.2-1.el7.x86_64  
    pinentry-0.8.1-17.el7.x86_64  
    python-perf-3.10.0-1127.8.2.el7.x86_64  
    grep-2.20-3.el7.x86_64  
    adobe-mappings-cmap-20171205-3.el7.noarch  
    nss-pem-1.0.3-7.el7.x86_64  
    jansson-2.10-1.el7.x86_64  
    mesa-libgbm-18.3.4-7.el7_8.1.x86_64  
    httpd-tools-2.4.6-93.el7.centos.x86_64  
    mesa-libGL-18.3.4-7.el7_8.1.x86_64  
    perl-TermReadKey-2.30-20.el7.x86_64  
    curl-7.29.0-57.el7.x86_64  
    libXinerama-1.1.3-2.1.el7.x86_64  
    php-xcache-3.1.1-1.el7.x86_64  
    php-common-5.4.16-48.el7.x86_64  
    libtasn1-4.10-1.el7.x86_64  
    libfontenc-1.1.3-3.el7.x86_64  
    php-xml-5.4.16-48.el7.x86_64  
    urw-base35-c059-fonts-20170801-10.el7.noarch  
    rpm-python-4.11.3-43.el7.x86_64  
    urw-base35-nimbus-roman-fonts-20170801-10.el7.noarch  
    geoipupdate-2.5.0-1.el7.x86_64  
    urw-base35-fonts-20170801-10.el7.noarch  
    bind-utils-9.11.4-16.P2.el7_8.3.x86_64  
    libmemcached-1.0.16-5.el7.x86_64  
    libtidy-5.4.0-1.el7.x86_64  
    libedit-3.0-12.20121213cvs.el7.x86_64  
    vim-minimal-7.4.629-6.el7.x86_64  
    net-snmp-libs-5.7.2-48.el7_8.x86_64  
    newt-0.52.15-4.el7.x86_64  
    kmod-libs-20-28.el7.x86_64  
    openjpeg2-2.3.1-3.el7_7.x86_64  
    gdbm-1.10-8.el7.x86_64  
    perl-HTTP-Tiny-0.033-3.el7.noarch  
    patch-2.7.1-12.el7_7.x86_64  
    fribidi-1.0.2-1.el7_7.1.x86_64  
    perl-Encode-2.51-7.el7.x86_64  
    make-3.82-24.el7.x86_64  
    libwayland-client-1.15.0-1.el7.x86_64  
    perl-Exporter-5.68-3.el7.noarch  
    ipset-libs-7.1-1.el7.x86_64  
    pango-1.42.4-4.el7_7.x86_64  
    perl-Carp-1.26-244.el7.noarch  
    libndp-1.2-9.el7.x86_64  
    isp-php71-7.1.33-417.el7.x86_64  
    kpartx-0.4.9-131.el7.x86_64  
    fipscheck-1.4.1-6.el7.x86_64  
    coremanager-pkg-ipset-5.259.0-1.el7.x86_64  
    perl-threads-shared-1.43-6.el7.x86_64  
    device-mapper-libs-1.02.164-7.el7_8.2.x86_64  
    ispmanager-pkg-exim-5.259.1-1.el7.x86_64  
    python-backports-ssl_match_hostname-3.5.0.1-1.el7.noarch  
    dbus-libs-1.10.24-13.el7_6.x86_64  
    coremanager-pkg-php-5.259.0-1.el7.x86_64  
    initscripts-9.49.49-1.el7.x86_64  
    ispmanager-pkg-awstats-5.259.1-1.el7.x86_64  
    snappy-1.1.0-3.el7.x86_64  
    libproxy-0.4.11-11.el7.x86_64  
    httpd-2.4.6-93.el7.centos.x86_64  
    ispmanager-pkg-nginx-5.259.1-1.el7.x86_64  
    grub2-tools-minimal-2.02-0.81.el7.centos.x86_64  
    ntpdate-4.2.6p5-29.el7.centos.x86_64  
    openssh-clients-7.4p1-21.el7.x86_64  
    python-pycurl-7.19.0-19.el7.x86_64  
    dhclient-4.2.5-79.el7.centos.x86_64  
    grub2-pc-2.02-0.81.el7.centos.x86_64  
    zip-3.0-11.el7.x86_64  
    mod_ssl-2.4.6-93.el7.centos.x86_64  
    perl-IO-Socket-IP-0.21-5.el7.noarch  
    dovecot-2.2.36-6.el7.x86_64  
    ppp-2.4.5-34.el7_7.x86_64  
    perl-Digest-SHA-5.85-4.el7.x86_64  
    ncurses-5.9-14.20130511.el7_4.x86_64  
    info-5.1-5.el7.x86_64  
    libxslt-1.1.28-5.el7.x86_64  
    python-iniparse-0.4-9.el7.noarch  
    plymouth-core-libs-0.8.9-0.33.20140113.el7.centos.x86_64  
    python-backports-1.0-8.el7.x86_64  
    kernel-tools-libs-3.10.0-1127.8.2.el7.x86_64  
    pyxattr-0.5.1-5.el7.x86_64  
    apr-util-1.5.2-6.el7.x86_64  
    libbsd-0.8.3-1.el7.x86_64  
    perl-Digest-MD5-2.52-3.el7.x86_64  
    libxcb-1.13-1.el7.x86_64  
    kbd-legacy-1.15.5-15.el7.noarch  
    gzip-1.5-10.el7.x86_64  
    NetworkManager-team-1.18.4-3.el7.x86_64  
    xz-libs-5.2.2-1.el7.i686  
    avahi-autoipd-0.6.31-20.el7.x86_64  
    libmcrypt-2.5.8-13.el7.x86_64  
    python-slip-0.4.0-4.el7.noarch  
    perl-Net-Daemon-0.48-5.el7.noarch  
    grub2-2.02-0.81.el7.centos.x86_64  
    tuned-2.11.0-8.el7.noarch  
    nginx-module-image-filter-1.16.1-1.el7.ngx.x86_64  
    perl-Mozilla-CA-20130114-5.el7.noarch  
    perl-Compress-Raw-Bzip2-2.061-3.el7.x86_64  
    mc-4.8.7-11.el7.x86_64  
    postfix-2.10.1-9.el7.x86_64  
    microcode_ctl-2.1-61.el7.x86_64  
    fxload-2002_04_11-16.el7.x86_64  
    libgudev1-219-73.el7_8.6.x86_64  
    libsoup-2.62.2-2.el7.x86_64  
    setup-2.8.71-11.el7.noarch  
    dar-2.5.22-1.el7.x86_64  
    php-pear-Net-Socket-1.0.14-1.el7.noarch  
    kbd-misc-1.15.5-15.el7.noarch  
    gnupg2-2.0.22-5.el7_5.x86_64  
    nss-softokn-freebl-3.44.0-8.el7_7.x86_64  
    json-c-0.11-4.el7_0.x86_64  
    nspr-4.21.0-1.el7.x86_64  
    zlib-1.2.7-18.el7.x86_64  
    fontpackages-filesystem-1.44-8.el7.noarch  
    libcom_err-1.42.9-17.el7.x86_64  
    perl-FCGI-0.74-8.el7.x86_64  
    libstdc++-4.8.5-39.el7.x86_64  
    findutils-4.5.11-6.el7.x86_64  
    perl-HTML-Tagset-3.20-15.el7.noarch  
    hostname-3.13-3.el7_7.1.x86_64  
    perl-5.16.3-295.el7.x86_64  
    iwl1000-firmware-39.31.5.1-76.el7.noarch  
    glibc-2.17-307.el7.1.i686  
    elfutils-libs-0.176-4.el7.i686  
    libcap-2.22-11.el7.i686  
    systemd-libs-219-73.el7_8.6.i686  
    php-fedora-autoloader-1.0.1-2.el7.noarch  
    php-tidy-5.4.16-9.el7.x86_64  
    libselinux-python-2.5-15.el7.x86_64  
    alsa-lib-1.1.8-1.el7.x86_64  
    iprutils-2.4.17.1-3.el7_7.x86_64  
    epel-release-7-12.noarch  
    iwl2000-firmware-18.168.6.1-76.el7.noarch  
    iwl135-firmware-18.168.6.1-76.el7.noarch  
    iwl6000g2b-firmware-18.168.6.1-76.el7.noarch  
    perl-Business-ISBN-Data-20120719.001-2.el7.noarch  
    file-5.11-36.el7.x86_64  
    nss-softokn-freebl-3.44.0-8.el7_7.i686  
    perl-WWW-RobotRules-6.02-5.el7.noarch  
    krb5-libs-1.15.1-46.el7.x86_64  
    liblockfile-1.08-17.el7.x86_64  
    audit-libs-2.8.5-4.el7.i686  
    glib2-2.56.1-5.el7.x86_64  
    libXrender-0.9.10-1.el7.x86_64  
    ncurses-libs-5.9-14.20130511.el7_4.x86_64  
    iproute-4.11.0-25.el7_7.2.x86_64  
    libSM-1.2.2-2.el7.x86_64  
    libxml2-python-2.9.1-6.el7.4.x86_64  
    ilmbase-1.0.3-7.el7.x86_64  
    nss-tools-3.44.0-7.el7_7.x86_64  
    libXcursor-1.1.15-1.el7.x86_64  
    openldap-2.4.44-21.el7_6.x86_64  
    xorg-x11-font-utils-7.5-21.el7.x86_64  
    rpm-build-libs-4.11.3-43.el7.x86_64  
    urw-base35-nimbus-sans-fonts-20170801-10.el7.noarch  
    bind-libs-9.11.4-16.P2.el7_8.3.x86_64  
    jbigkit-libs-2.0-11.el7.x86_64  
    e2fsprogs-libs-1.42.9-17.el7.x86_64  
    less-458-9.el7.x86_64  
    libwebp-0.3.0-7.el7.x86_64  
    perl-podlators-2.5.1-3.el7.noarch  
    linux-firmware-20191203-76.gite8a0f4c.el7.noarch  
    libglvnd-egl-1.0.1-0.8.git5baa1e5.el7.x86_64  
    perl-constant-1.27-2.el7.noarch  
    libseccomp-2.3.1-4.el7.x86_64  
    perl-Pod-Simple-3.28-4.el7.noarch  
    perl-Net-SSLeay-1.55-6.el7.x86_64  
    kmod-20-28.el7.x86_64  
    ispmanager-pkg-logrotate-5.259.1-1.el7.x86_64  
    python-slip-dbus-0.4.0-4.el7.noarch  
    elfutils-default-yama-scope-0.176-4.el7.noarch  
    ispmanager-pkg-proftpd-5.259.1-1.el7.x86_64  
    cronie-1.4.11-23.el7.x86_64  
    libverto-0.2.5-4.el7.x86_64  
    openssh-7.4p1-21.el7.x86_64  
    cracklib-dicts-2.9.0-11.el7.x86_64  
    python-gobject-base-3.22.0-1.el7_4.1.x86_64  
    grub2-tools-extra-2.02-0.81.el7.centos.x86_64  
    libXpm-3.5.12-1.el7.x86_64  
    portreserve-0.0.5-11.el7.x86_64  
    gpg-pubkey-810f8996-552b1d92.(none)  
    btrfs-progs-4.9.1-1.el7.x86_64  
    at-3.1.13-24.el7.x86_64  
    gpg-pubkey-352c64e5-52ae6884.(none)  
    yum-metadata-parser-1.1.4-10.el7.x86_64  
    perl-Data-Dumper-2.145-3.el7.x86_64  
    libfastjson-0.99.4-3.el7.x86_64  
    perl-Encode-Locale-1.03-5.el7.noarch  
    cyrus-sasl-lib-2.1.26-23.el7.x86_64  
    libgpg-error-1.12-3.el7.i686  
    perl-Switch-2.16-7.el7.noarch  
    perl-Net-IP-1.26-4.el7.noarch  
    openssh-server-7.4p1-21.el7.x86_64  
    audit-2.8.5-4.el7.x86_64  
    biosdevname-0.7.3-2.el7.x86_64  
    libgcc-4.8.5-39.el7.x86_64  
    sudo-1.8.23-9.el7.x86_64  
    pygpgme-0.3-9.el7.x86_64  
    php-pear-Net-LDAP2-2.1.0-1.el7.noarch  
    libX11-common-1.6.7-2.el7.noarch  
    php-bcmath-5.4.16-48.el7.x86_64  
    libpipeline-1.2.3-3.el7.x86_64  
    php-pear-Net-IDNA2-0.1.1-10.el7.noarch  
    nss-util-3.44.0-4.el7_7.x86_64  
    fontconfig-2.13.0-4.3.el7.x86_64  
    dejavu-fonts-common-2.33-6.el7.noarch  
    libxml2-2.9.1-6.el7.4.x86_64  
    htop-2.2.0-3.el7.x86_64  
    perl-TimeDate-2.30-2.el7.noarch  
    readline-6.2-11.el7.x86_64  
    iwl7260-firmware-25.30.13.0-76.el7.noarch  
    t1lib-5.1.2-14.el7.x86_64  
    libsemanage-2.5-14.el7.x86_64  
    iwl6000g2a-firmware-18.168.6.1-76.el7.noarch  
    aic94xx-firmware-30-6.el7.noarch  
    perl-HTTP-Message-6.06-6.el7.noarch  
    apr-1.4.8-5.el7.x86_64  
    libnetfilter_conntrack-1.0.6-1.el7_3.x86_64  
    libselinux-2.5-15.el7.i686  
    libblkid-2.23.2-63.el7.x86_64  
    libstdc++-4.8.5-39.el7.i686  
    rootfiles-8.1-11.el7.noarch  
    logrotate-3.8.6-19.el7.x86_64  
    authconfig-6.2.8-30.el7.x86_64  
    unixODBC-2.3.1-14.el7.x86_64  
    gettext-libs-0.19.8.1-3.el7.x86_64  
    libwayland-server-1.15.0-1.el7.x86_64  
    bind-export-libs-9.11.4-16.P2.el7_8.3.x86_64  
    libgcrypt-1.5.3-14.el7.x86_64  
    libXdamage-1.1.4-4.1.el7.x86_64  
    libdb-utils-5.3.21-25.el7.x86_64  
    libXxf86misc-1.0.3-7.1.el7.x86_64  
    php-pdo-5.4.16-48.el7.x86_64  
    p11-kit-trust-0.23.5-3.el7.x86_64  
    tcp_wrappers-libs-7.6-77.el7.x86_64  
    urw-base35-nimbus-mono-ps-fonts-20170801-10.el7.noarch  
    yum-3.4.3-167.el7.centos.noarch  
    which-2.20-7.el7.x86_64  
    harfbuzz-1.7.5-2.el7.x86_64  
    libdar-2.5.22-1.el7.x86_64  
    libnfnetlink-1.0.1-4.el7.x86_64  
    pixman-0.34.0-1.el7.x86_64  
    glib-networking-2.56.1-1.el7.x86_64  
    libgs-9.25-2.el7_7.3.x86_64  
    perl-Pod-Usage-1.63-3.el7.noarch  
    gpm-libs-1.20.7-6.el7.x86_64  
    ImageMagick-6.9.10.68-3.el7.x86_64  
    perl-PathTools-3.40-5.el7.x86_64  
    ebtables-2.0.10-16.el7.x86_64  
    procps-ng-3.3.10-27.el7.x86_64  
    ispmanager-lite-common-5.259.1-1.el7.x86_64  
    perl-Filter-1.49-3.el7.x86_64  
    elfutils-libs-0.176-4.el7.x86_64  
    ispmanager-pkg-myadmin-5.259.1-1.el7.x86_64  
    nano-2.3.1-10.el7.x86_64  
    nginx-1.16.1-1.el7.ngx.x86_64  
    polkit-0.112-26.el7.x86_64  
    git-1.8.3.1-22.el7_8.x86_64  
    bzip2-libs-1.0.6-13.el7.x86_64  
    php-5.4.16-48.el7.x86_64  
    NetworkManager-1.18.4-3.el7.x86_64  
    python-decorator-3.4.0-3.el7.noarch  
    libidn-1.28-4.el7.x86_64  
    pyliblzma-0.5.3-11.el7.x86_64  
    pwgen-2.08-1.el7.x86_64  
    mailcap-2.1.41-2.el7.noarch  
    libteam-1.29-1.el7.x86_64  
    perl-Digest-HMAC-1.03-5.el7.noarch  
    php-gd-5.4.16-48.el7.x86_64  
    php-tcpdf-6.2.26-1.el7.noarch  
    kernel-tools-3.10.0-1127.8.2.el7.x86_64  
    kernel-3.10.0-862.14.4.el7.x86_64  
    NetworkManager-tui-1.18.4-3.el7.x86_64  
    libcap-ng-0.7.5-4.el7.i686  
    perl-IO-HTML-1.00-2.el7.noarch  
    nginx-module-perl-1.16.1-1.el7.ngx.x86_64  
    perl-PlRPC-0.2020-14.el7.noarch  
    rdma-core-22.4-2.el7_8.x86_64  
    gperftools-libs-2.6.1-1.el7.x86_64  
    libzip-0.10.1-8.el7.x86_64  
    par2cmdline-0.8.0-1.el7.x86_64  
    dracut-config-rescue-033-568.el7.x86_64  
    trousers-0.3.14-2.el7.x86_64  
    php-pear-1.9.4-21.el7.noarch  
    libgcc-4.8.5-39.el7.i686  
    php-ldap-5.4.16-48.el7.x86_64  
    hardlink-1.0-19.el7.x86_64  
    glibc-2.17-307.el7.1.x86_64  
    passwd-0.79-6.el7.x86_64  
    libuser-0.60-9.el7.x86_64  
    audit-libs-2.8.5-4.el7.x86_64  
    perl-Pod-Escapes-1.04-295.el7.noarch  
    clucene-core-2.3.3.4-11.el7.x86_64  
    expat-2.1.0-11.el7.x86_64  
    iwl5000-firmware-8.83.5.1_1-76.el7.noarch  
    perl-macros-5.16.3-295.el7.x86_64  
    iwl5150-firmware-8.24.2.2-76.el7.noarch  
    perl-URI-1.60-9.el7.noarch  
    nss-softokn-3.44.0-8.el7_7.x86_64  
    elfutils-libelf-0.176-4.el7.i686  
    lua-5.1.4-15.el7.x86_64  
    shadow-utils-4.6-5.el7.x86_64  
    roundcubemail-1.1.12-2.el7.noarch  
    lz4-1.7.5-3.el7.i686  
    ncurses-base-5.9-14.20130511.el7_4.noarch  
    libcroco-0.6.12-4.el7.x86_64  
    libXfixes-5.0.3-1.el7.x86_64  
    popt-1.13-16.el7.x86_64  
    lz4-1.7.5-3.el7.x86_64  
    ivtv-firmware-20080701-26.el7.noarch  
    libXxf86vm-1.1.4-1.el7.x86_64  
    grubby-8.28-26.el7.x86_64  
    gpg-pubkey-f4a80eb5-53a7ff4b.(none)  
    adobe-mappings-cmap-deprecated-20171205-3.el7.noarch  
    p11-kit-0.23.5-3.el7.x86_64  
    wget-1.14-18.el7_6.1.x86_64  
    libXft-2.3.2-2.el7.x86_64  
    php-cli-5.4.16-48.el7.x86_64  
    urw-base35-p052-fonts-20170801-10.el7.noarch  
    yum-plugin-fastestmirror-1.1.31-54.el7_8.noarch  
    perl-interpreter-5.16.3-6.el7.noarch  
    urw-base35-gothic-fonts-20170801-10.el7.noarch  
    php-pear-Mail-Mime-1.10.2-1.el7.noarch  
    libicu-50.2-4.el7_7.x86_64  
    gdk-pixbuf2-2.36.12-3.el7.x86_64  
    gnutls-3.3.29-9.el7_6.x86_64  
    perl-parent-0.225-244.el7.noarch  
    pth-2.0.7-23.el7.x86_64  
    libthai-0.1.14-9.el7.x86_64  
    python-pyudev-0.15-9.el7.noarch  
    openssl-1.0.2k-19.el7.x86_64  
    perl-Storable-2.45-3.el7.x86_64  
    cairo-1.15.12-4.el7.x86_64  
    dbus-glib-0.100-7.el7.x86_64  
    python-schedutils-0.4-6.el7.x86_64  
    libsmartcols-2.23.2-63.el7.x86_64  
    perl-Scalar-List-Utils-1.27-248.el7.x86_64  
    coremanager-pkg-mysql-5.259.0-1.el7.x86_64  
    cryptsetup-libs-2.0.3-6.el7.x86_64  
    perl-IO-Socket-SSL-1.94-7.el7.noarch  
    qrencode-3.4.1-3.el7.x86_64  
    ispmanager-pkg-mysql-5.259.1-1.el7.x86_64  
    systemd-sysv-219-73.el7_8.6.x86_64  
    autogen-libopts-5.18-5.el7.x86_64  
    perl-DBD-MySQL-4.023-6.el7.x86_64  
    ispmanager-plugin-letsencrypt-5.259.1-1.el7.x86_64  
    ustr-1.0.4-16.el7.x86_64  
    grub2-tools-2.02-0.81.el7.centos.x86_64  
    python-kitchen-1.1.1-5.el7.noarch  
    perl-Git-1.8.3.1-22.el7_8.noarch  
    selinux-policy-3.13.1-266.el7.noarch  
    libutempter-1.1.6-4.el7.x86_64  
    wpa_supplicant-2.6-12.el7.x86_64  
    libunwind-1.2-2.el7.x86_64  
    lzo-2.06-8.el7.x86_64  
    fcgi-2.4.0-25.el7.x86_64  
    numactl-libs-2.0.12-5.el7.x86_64  
    perl-LWP-MediaTypes-6.02-2.el7.noarch  
    libX11-1.6.7-2.el7.x86_64  
    irqbalance-1.0.7-12.el7.x86_64  
    perl-Net-LibIDN-0.12-15.el7.x86_64  
    cracklib-2.9.0-11.el7.i686  
    centos-logos-70.0.6-3.el7.centos.noarch  
    NetworkManager-ppp-1.18.4-3.el7.x86_64  
    polkit-pkla-compat-0.1-4.el7.x86_64  
    yum-cron-3.4.3-167.el7.centos.noarch  
    libevent-2.0.21-4.el7.x86_64  
    kernel-3.10.0-1127.8.2.el7.x86_64  
    perl-DBI-1.627-4.el7.x86_64  
    gawk-4.0.2-4.el7_3.1.x86_64  
    alsa-firmware-1.0.28-2.el7.noarch  
    parted-3.1-32.el7.x86_64  
    php-intl-5.4.16-48.el7.x86_64  
    php-pear-Auth-SASL-1.0.6-5.el7.noarch  
    grub2-pc-modules-2.02-0.81.el7.centos.noarch  
    gobject-introspection-1.56.1-1.el7.x86_64  
    bash-4.2.46-34.el7.x86_64  
    man-db-2.6.3-11.el7.x86_64  
    libcap-2.22-11.el7.x86_64  
    iwl6000-firmware-9.221.4.1-76.el7.noarch  
    elfutils-libelf-0.176-4.el7.x86_64  
    iwl105-firmware-18.168.6.1-76.el7.noarch  
    perl-Socket-2.010-5.el7.x86_64  
    

    Результатом запроса на сайте будет перечисление пакетов, содержащих известные уязвимости.

    file

    file

    После вывода пакетов, возможно отобразить решение, нажав кнопку How to fix


    Если у Вас возникли трудности в настройке или появились дополнительные вопросы, вы всегда можете обращаться в нашу службу поддержки через систему тикетов.